Download the program for the device via the Internet.

For Flowcode users to discuss projects, flowcharts, and any other issues related to Flowcode 8.

Moderator: Benj

Post Reply
chipfryer27
Valued Contributor
Valued Contributor
Posts: 772
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 185 times
Been thanked: 204 times
Contact:

Re: Download the program for the device via the Internet.

Post by chipfryer27 »

Hi

Yes, it is the same blank file, just used in various places as referenced by the Hex.

Regards

chipfryer27
Valued Contributor
Valued Contributor
Posts: 772
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 185 times
Been thanked: 204 times
Contact:

Re: Download the program for the device via the Internet.

Post by chipfryer27 »

Hi

There is absolutly tons of info on the esp8266 out there, some good, some bad and some terrible and it is a bit like herding cats. I doubt if there ever will be a fully comprehensive guide to them, rather some "good suggestions to try" :lol:

Espressif seemed to subcontract / licence out manufacture which means info is fragmented and may not translate well. Updates may not have any regard to previous capabilities either meaning they may not be 100% backwards compatible.

Although my previous posts illustrated how to update, all were only guides for use with a similar working module. Hopefully the above will allow even a "bricked" module to be updated.

Regards

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good evening! Today I tried to upload the files that you indicated to me in that order to the new program and to the old one. Nothing worked out everywhere. In the old one, I also changed the connection ports and speeds, the same did not help. I noticed that you have inscriptions in the program window "MAC Address" and "DETECTED INFO" -I did not have such inscriptions and that you have on different screenshots, where the file location is indicated, then a selection button (with three dots) and a hex address-so in different screenshots, different addresses. If you delete them, new ones do not appear, that is, when you turn on the program, they are already there. Is it unclear where the files will be written to? I attached the screenshots of the logs, maybe something is more visible to you there than to me, I just saw that there was no synchronization and the port was closed.
Attachments
log2.jpg
log2.jpg (71.97 KiB) Viewed 1278 times
log1.jpg
log1.jpg (56.47 KiB) Viewed 1278 times
1.JPG
1.JPG (154.97 KiB) Viewed 1278 times

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good evening! Another additional log. Maybe, as an option, try the connection scheme as on the website, with resistors and capacitors.
Attachments
log3.jpg
log3.jpg (119.05 KiB) Viewed 1278 times

chipfryer27
Valued Contributor
Valued Contributor
Posts: 772
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 185 times
Been thanked: 204 times
Contact:

Re: Download the program for the device via the Internet.

Post by chipfryer27 »

Hi

From your screenshots you are not connecting to the esp8266.

1) Have you set the correct comm port? Nothing else can be using it at the same time. Close Terminal or anything else that may be using it.
2) Did you press and hold reset, then flash, then release reset, then release flash before pressing Start? It will not go into programming mode unless you do this and therefore will not communicate with the flash tool.
3) You have not entered the required Hex addresses. These values need to be entered as documented (but only later)

Please don't just send a post saying it does not work, instead follow my guide from the beginning. If at any stage it doesn't work as described, stop, take a screenshot and document exactly what you did up to that point. That is more helpful.

If you follow my post, you will see that in the first two pictures we connect to the chip and the flash tool obtains settings from the chip which are populated in Detected Info and MAC Address. If you are not getting that far then nothing else will work. Only after that we set file paths and hex addresses.

I didn't need the resistors and capacitors but as mentioned in my post I had to try putting it into "flash mode" a couple of times until the module returned "Detected Info" after pressing Start, which could have been my breadboard connections.

115200 will be the speed it communicates at when in "flash mode". Even a "bricked" module will still run at that speed.

Follow my post, step by step and if something doesn't work stop and document.

Regards

chipfryer27
Valued Contributor
Valued Contributor
Posts: 772
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 185 times
Been thanked: 204 times
Contact:

Re: Download the program for the device via the Internet.

Post by chipfryer27 »

PS

If you can use Terminal to connect and successfully issue "AT" commands, take note of the comm port used, close Terminal, then open flash tool and select the same comm port.

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good morning! Thank you very much for your explanation! You see, I correctly noticed that the program does not receive information from the chip, and you explained the reason. There is no connection. I cannot now (after I have soldered the wires and buttons for programming) send commands AT and receive a response, it would be more accurate to say I send commands, but I do not receive answers. I probably put together the programming scheme incorrectly.

chipfryer27
Valued Contributor
Valued Contributor
Posts: 772
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 185 times
Been thanked: 204 times
Contact:

Re: Download the program for the device via the Internet.

Post by chipfryer27 »

Hi

Happy to help where / if I can.

Double check connections and also comm port. Numerous times I have forgotten to set it correctly :oops:

Regards

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good evening! I think I found the reason why it doesn't work for me. I have a computer under the table and in order not to bend over, I began to use a usb extension cable and when I insert the usb-ttl adapter, it does not connect and the port in the "terminal" program is not correctly detected. And I insert it directly, everything turns on, the device connection signal occurs and the port is correctly detected and the esp8266 module responds normally to the "AT" command.Today I will only have time to restore the chain and check it. I will be able to try to reprogram the module only on Tuesday after 4 p.m.

chipfryer27
Valued Contributor
Valued Contributor
Posts: 772
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 185 times
Been thanked: 204 times
Contact:

Re: Download the program for the device via the Internet.

Post by chipfryer27 »

Hi

Good to hear you have identified the issue. When you are ready to try again, do the following but if any fail, don't move on-

1) Connect to module using "Terminal" and ensure you can send AT and receive OK. If not check why. Once working take note of comm port being used.

2) Close "Terminal" and open Flash Tool as per my post.

3) Ensure comm port is correct and speed is 115200

4) Put esp into "flash mode" as per post by pressing and holding reset, press and hold Flash (GPIO-0), release reset, release Flash.

5) Press Start in Flash tool. If after a few seconds you don't get any responce try it all again (points 3, 4 & 5). If it constantly fails stop.

Once the module responds then fill in the file paths and hex addresses etc.

Good luck.

Regards

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good evening! I congratulate you and all those present on the upcoming holidays! Unfortunately, my happy news ended there. I stopped and am still sorting out 1 point. After connecting the wires and buttons, it is not possible to receive a response through the terminal program after sending the AT command. Now I'm looking for the cause of the malfunction.

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good evening! It was possible to find the reason why it was not possible to program or receive answers in the terminal program-it connected the RX and TX pins incorrectly. It was possible to reprogram, but it writes in the log that 99% was completed, not 100%. But after connecting to the terminal program, it is not possible to receive any response. I have done programming 2 times, but there is no result.
Attachments
the module does not respond to commands after programming.jpg
the module does not respond to commands after programming.jpg (62.84 KiB) Viewed 1166 times
The programming process.JPG
The programming process.JPG (120.17 KiB) Viewed 1166 times
The programming seems to have gone well.JPG
The programming seems to have gone well.JPG (126.48 KiB) Viewed 1166 times

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good evening! I also noticed that when you start programming, you press the start button, the SPI MOD jumps from QIO mode to DIO mode itself. When I tried to reprogram it 3 times, as soon as it switched, I turned it on to QIO mode myself, programming also passed and the terminal program still does not respond to commands.

chipfryer27
Valued Contributor
Valued Contributor
Posts: 772
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 185 times
Been thanked: 204 times
Contact:

Re: Download the program for the device via the Internet.

Post by chipfryer27 »

Hi

That's good you are getting the responses documented in your post. You are almost there.

You forgot however to enter the correct Hex values in the Address boxes

File / Hex Address

blank / 0xfb000
esp_init_data_default_v08 / 0xfc000
blank / 0x7e000
blank / 0xfe000
boot_v1.7 / 0x00000
user1.1024.new.2 / 0x01000

If the files are not in the correct addresses then it won't work..

If you enter the files and addresses as shown you should be good.

Regards

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good afternoon! Happy Spring and Labor Day! Thanks for the tip!. I'll check it out soon. From the outside it looks like the transfer of secret magic spells! :)

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good afternoon! Unfortunately, the module is still silent and does not respond to commands after it has been reprogrammed.(changed addresses). The results are in the screenshots.
Attachments
nothing has changed, the module is not responding.JPG
nothing has changed, the module is not responding.JPG (65.78 KiB) Viewed 1115 times
new_address.JPG
new_address.JPG (120.69 KiB) Viewed 1115 times

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good afternoon! I also forgot to attach a screenshot of the program logs, where you can see which files I selected and to which address I was going to send.
Attachments
log_new_address.JPG
log_new_address.JPG (124.85 KiB) Viewed 1108 times

chipfryer27
Valued Contributor
Valued Contributor
Posts: 772
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 185 times
Been thanked: 204 times
Contact:

Re: Download the program for the device via the Internet.

Post by chipfryer27 »

Hi

Unfortunately a screenshot of a partial log isn't of much help here.

Can you copy the log and paste into a text / word documents and send that?

Regards

chipfryer27
Valued Contributor
Valued Contributor
Posts: 772
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 185 times
Been thanked: 204 times
Contact:

Re: Download the program for the device via the Internet.

Post by chipfryer27 »

PS

Try using QIO for SPI Mode, not DIO

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good afternoon! I did as you asked. View the log file in the attached text document. But I want to note that the situation with the QIO regime has repeated itself. After pressing the start button, it jumps to DIO itself. And I immediately rearrange it manually in QIO.
Attachments
log.pdf
(49.44 KiB) Downloaded 28 times
log.txt
(7.55 KiB) Downloaded 56 times

chipfryer27
Valued Contributor
Valued Contributor
Posts: 772
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 185 times
Been thanked: 204 times
Contact:

Re: Download the program for the device via the Internet.

Post by chipfryer27 »

Hi

I'll compare against mine later tonight.

If it is jumping to DIO by itself then it is overiding the setting of QIO as SpiAutoSet is checked. Not sure why it is choosing DIO over QIO. Maybe try it without SpiAutoSet checked?

Stupid question time (as in your earlier post it did look as though you loaded) but did you remember to reset or reboot the ESP module afterwards and also to disconnect the Flash tool (as the tool would still be in command of the comm port)?

Regards

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good evening! Yes, I'm going to try to check your version of the SpiAutoSet flags now. Before checking the passage of the command in the terminal program, I exited the programming program and took out and put back the usb-ttl adapter with the module (for the purity of the experiment).

chipfryer27
Valued Contributor
Valued Contributor
Posts: 772
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 185 times
Been thanked: 204 times
Contact:

Re: Download the program for the device via the Internet.

Post by chipfryer27 »

Hi

No real need to unplug the adapter but you do need to close the flash tool and also reset the esp.

There is a slight chance that when you unplugged the adapter and then reinserted it assigned a different port (unlikely) but if you hadn't reset (or removed power then repowered) the esp it would still be in program mode and unresponsive.

Regards

gilanetugila
Posts: 268
Joined: Thu Jul 30, 2020 2:01 pm
Has thanked: 7 times
Been thanked: 1 time
Contact:

Re: Download the program for the device via the Internet.

Post by gilanetugila »

Good evening! I have now checked your version about the uncheck SpiAutoSet setting-it worked, stopped jumping from QIO to DIO at the beginning of programming. But when passing commands through the terminal program, nothing has changed. There is no response to the "AT" command. The attached files contain the program log.
Attachments
log_NO_SpiAutoSET.pdf
(48.88 KiB) Downloaded 31 times
log_NO_SpiAutoSET.txt
(7.42 KiB) Downloaded 12 times

chipfryer27
Valued Contributor
Valued Contributor
Posts: 772
Joined: Fri Jun 06, 2014 3:53 pm
Has thanked: 185 times
Been thanked: 204 times
Contact:

Re: Download the program for the device via the Internet.

Post by chipfryer27 »

Hi

Again, stupid question. Did you reset the esp and close Flash?

Regards

Post Reply